NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: NetXMS 2.2.15 released  (Read 3585 times)

Victor Kirhenshtein

  • Lead Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 6589
    • View Profile
NetXMS 2.2.15 released
« on: May 24, 2019, 07:37:44 pm »

Hi all!

NetXMS version 2.2.15 is available. It is mostly hotfix release for issues found in version 2.2.14. Full change log is following:

- Improved driver for Cisco Small Business switches
- Fixed issues:
        NX-1609 (Duplicate server configuration parameters)
        NX-1627 (Proxy node should not ping through itself)
        NX-1637 (Unrecognized Cisco SG Switch)
        NX-1639 (NXSL persistent storage entries not saved in database)
        NX-1644 (DB gets corrupted when adding container/nodes)
        NX-1645 (Broken UI element layout in table DCI "General" property page)

It is highly recommended to run nxdbmgr check after upgrading binaries and before first server start.

Best regards,
Victor
Logged

gociux

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: NetXMS 2.2.15 released
« Reply #1 on: May 30, 2019, 04:59:44 pm »

Hello Rohin,

I'm having some issues with my Netxms - web interface - i have "Server uses incompatible version of communication protocol (server=[48,2,1,1,1,18,1,2] client=[48,2,1,1,1,12])

Need to mention that i installed server version 2.2.15.2 and Web interface (war) 2.2.15.

Is this error reported because the war is not the same as the server?

Thanks,
Mihai
Logged

vasnam23

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: NetXMS 2.2.15 released
« Reply #2 on: June 20, 2019, 11:19:24 pm »

I get this error during windows agent installation. I used older agent 2.2.12 installer, no error during install, 2.2.12 -> 2.2.15 upgrade no error also.

Logged