NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: DS18X20 Sensor on RPI config problem  (Read 57 times)

Eisbaeeer

  • Newbie
  • *
  • Posts: 5
    • View Profile
DS18X20 Sensor on RPI config problem
« on: November 12, 2019, 08:55:54 am »

Hi
I run into config problems with OneWire Sensor.
The subAgent is loading but always got the message:

Code: [Select]
2019.11.12 07:47:00.477 *W* Unable to add sensor from configuration file. Original configuration record:
2019.11.12 07:47:00.478 *I* Subagent "DS18X20" (ds18x20.nsm) loaded successfully (version 2.2.8)

The sensor is working and I got some temperatures from it:

Code: [Select]
:/sys/bus/w1/devices/28-0000022801e4# cat w1_slave
35 01 4b 46 7f ff 0b 10 31 : crc=31 YES
35 01 4b 46 7f ff 0b 10 31 t=19312

The config looks like this, but tried some other things more by try-and-error:

Code: [Select]
SubAgent = ds18x20.nsm

# 1Wire Seonsors
[DS18X20]
Sensor = Test:28-0000022801e4

Are there anybody who can provide a working "config" or has hints of that issue?
A higher debug level donĀ“t tell me more informations about the config problem.

Thank you guys for your help!
Logged