Author Topic: Plagued with DCI collection errors  (Read 3550 times)

DH

  • Jr. Member
  • **
  • Posts: 63
    • View Profile
Plagued with DCI collection errors
« on: February 20, 2014, 04:14:08 pm »
Hi,

 Since upgrading to 1.2.12 we have been getting lots of DCI collection errors in the NetXMS Console which we never got with 1.2.11. A dialogue is thrown up titled "Multiple problems have occurred", below the title it says "Cannot get DCI values for node XXXXXXX. Software caused connection abort: socket write error".

 The console platform is Windows 7 (64bit)
 The server platform is Windows 2008 R2

 A restart of the console seems to cure the problem for a few hours.

Regards,
David

DH

  • Jr. Member
  • **
  • Posts: 63
    • View Profile
Re: Plagued with DCI collection errors
« Reply #1 on: February 20, 2014, 05:10:22 pm »
Further information, a browser based console on the same host as the NetXMS console comes up with the same errors. In the console if I click ok past the error dialogue the 'last values' page on the node is empty, restart the console and it is all back to normal.

Regards,
David

Victor Kirhenshtein

  • Lead Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 7137
    • View Profile
Re: Plagued with DCI collection errors
« Reply #2 on: February 20, 2014, 07:53:09 pm »
Hi!

Seems like common problem, there are few other very similar bug reports. We are trying to reproduce it and fix.

Best regards,
Victor

Sympology

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: Plagued with DCI collection errors
« Reply #3 on: March 28, 2014, 04:35:28 pm »
Just to let you know I'm getting this as well, I'll try the latest version as soon as I can and let you know how I get on.

Client:
Windows 7 32bit
Windows 8 64bt

Server
Windows Server 2003 32bit

FYI originally we had it on MySQL, but exported the DB and wiped machine and reloaded it with SQLite and reimported DB

andrey--k

  • Full Member
  • ***
  • Posts: 216
    • View Profile
Re: Plagued with DCI collection errors
« Reply #4 on: March 28, 2014, 05:36:30 pm »
Is this error apears in latest (1.2.13) nxmc version?

Sympology

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: Plagued with DCI collection errors
« Reply #5 on: March 28, 2014, 05:44:14 pm »
I've just upgraded to .13 so I'll know by Monday morning  :)

Sympology

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: Plagued with DCI collection errors
« Reply #6 on: March 31, 2014, 12:04:12 pm »
Just to let you know, I did the upgrade on Friday and it stayed up all weekend. This compared with it failing after a few hours, so certainly looking better.

Sympology

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: Plagued with DCI collection errors
« Reply #7 on: April 11, 2014, 12:52:31 pm »
Ok, it was up for a week, and all was fine. Then added the webserver and it falls over again, this time with historic issues. I've had problems with the webclient in the past, so not (at this stage) convinced that it is the same issue. I've stopped the server again and seems stable.
Like I said, i think it's my setup that has the issue and I'll work on that another day.

Stu..

DH

  • Jr. Member
  • **
  • Posts: 63
    • View Profile
Re: Plagued with DCI collection errors
« Reply #8 on: April 11, 2014, 12:58:15 pm »
Hi,

 We've been running 1.2.13 for a couple of weeks and the DCI collection errors has not re-appeared since the upgrade, looks solved here.

Regards,
David