NetXMS Support Forum

English Support => General Support => Topic started by: stevenlamb on April 13, 2015, 11:57:40 pm

Title: 2.0-M3 installed getting incompatible communication Protocal
Post by: stevenlamb on April 13, 2015, 11:57:40 pm
i recently installed a new server on Debian

I installed from the Apt-get Repositories. it installed 2.0-M3. as best i can tell it seems to be installed and running correctly. I seem to be unable to find a MC that will connect to it successfully. i seem to get the error "Server uses incompatible version of communication protocol". i get this error when using the War file installed locally on tomcat. i get this error when i use the standalone webui. i have made sure that i downloaded the devel version of the ui.

am i missing something. are there some log files to help track down what i am missing.

Thanks

Title: Re: 2.0-M3 installed getting incompatible communication Protocal
Post by: Victor Kirhenshtein on April 14, 2015, 09:40:46 am
Hi,

please send result of command

netxmsd -v

and version and build number shown in bottom right corner of Web UI login screen.

Best regards,
Victor
Title: Re: 2.0-M3 installed getting incompatible communication Protocal
Post by: stevenlamb on April 14, 2015, 04:18:21 pm
NetXMS Server Version 2.0-M2 Build 8009 (UNICODE)

Version2.0-M-3 (8012)
Title: Re: 2.0-M3 installed getting incompatible communication Protocal
Post by: stevenlamb on April 14, 2015, 05:32:06 pm
I feel a little silly assuming the version of server was M3, instead of M2. I have dug through the archives and and trying to get a M2 UI installed to see if this resolves my issue. I will update once I try this. I will also repost build numbers once I have done this
Title: Re: 2.0-M3 installed getting incompatible communication Protocal
Post by: stevenlamb on April 14, 2015, 05:44:02 pm
I now feel double silly. it works with the correct version. thank you for your attention on this.

to be clear. i followed the instructions on the youtube video and made a mistake assuming that the devel version was the same as what i got from apt. once i found the same version in the archives it worked as expected.

SOLVED
Title: Re: 2.0-M3 installed getting incompatible communication Protocal
Post by: tomaskir on April 14, 2015, 05:56:37 pm
I now feel double silly. it works with the correct version. thank you for your attention on this.

to be clear. i followed the instructions on the youtube video and made a mistake assuming that the devel version was the same as what i got from apt. once i found the same version in the archives it worked as expected.

SOLVED
The NetXMS apt repo is currently being migrated to a singed repo and there are a few issues, causing 2.0-M3 to not be present in the apt repo yet.

Should be resolved soon (hopefully).

Sorry for the issues it caused you :)