NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: configure: error: libmysqlclient is required for MySQL support  (Read 5536 times)

hamad

  • Newbie
  • *
  • Posts: 8
    • View Profile
configure: error: libmysqlclient is required for MySQL support
« on: December 19, 2011, 10:09:03 am »

Hello
I get the following error when I try to install netxms-1.1.7 on CentOS

./configure  --with-server --with-mysql --with-agent   

checking for mysql_init in -lmysqlclient... no
configure: error: libmysqlclient is requred for MySQL support

configure:20702: checking for mysql_init in -lmysqlclient
configure:20727: gcc -o conftest -g -O2  -D_THREAD_SAFE -I/usr/local/mysql/include -I/usr/include/mysql -I/usr/mysql/include -I/usr/local/include/mysql -I/us
r/local/mysql/include/mysql -I/usr/mysql/include/mysql -D_GNU_SOURCE -Wno-unused-result -I/usr/local/include -lm -L/usr/local/mysql/lib -L/usr/lib64/mysql -L
/usr/lib/mysql -L/usr/mysql/lib -L/usr/local/lib/mysql -L/usr/local/mysql/lib/mysql -L/usr/mysql/lib/mysql -L/usr/local/lib conftest.c -lmysqlclient  -lz -ld
l  -lpthread >&5
/usr/bin/ld: cannot find -lmysqlclient


Help Please
Logged

Victor Kirhenshtein

  • Lead Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 6533
    • View Profile
Re: configure: error: libmysqlclient is required for MySQL support
« Reply #1 on: December 19, 2011, 11:26:22 am »

Hi!

You have to install mysql client library package. For CentOS 5 it probably would be mysql-devel.

Best regards,
Victor
Logged

testos

  • Full Member
  • ***
  • Posts: 157
    • View Profile
Re: configure: error: libmysqlclient is required for MySQL support
« Reply #2 on: December 19, 2011, 11:33:22 am »

To check advised by Victor, you can run the following command:

# rpm -qa | grep -i mysql


And if not, you can install it with:

# yum install mysql-devel


Best regards.
Logged

hamad

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: configure: error: libmysqlclient is required for MySQL support
« Reply #3 on: December 19, 2011, 11:51:29 am »

It worked :)

Thanks for the support
Logged