NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: deb packages install on Debian 8.3[ERROR] Unable to load database driver module  (Read 1640 times)

allway

  • Newbie
  • *
  • Posts: 3
    • View Profile

version 2.01 amd64 use the deb packages install on Debian 8.3 will got the error log:
[ERROR] Unable to load database driver module "": /usr/lib/x86_64-linux-gnu/netxms/dbdrv/: cannot read file data: Is a directory
Logged

Alex Kirhenshtein

  • Team Member
  • Administrator
  • Hero Member
  • *****
  • Posts: 913
    • View Profile

check "DBDriver" field in configuration file.
Logged

allway

  • Newbie
  • *
  • Posts: 3
    • View Profile

/etc/netxmsd.conf
DBDriver=sqlite.ddr
Logged

allway

  • Newbie
  • *
  • Posts: 3
    • View Profile

sorry i foget run nxdbmgr init /usr/share/netxms/sql/dbinit_sqlite.sql to init the db ,
after run it , the server start without error
thank!
Logged