NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: Installing 0.2.14 (upgrading from 0.2.13) on Linux  (Read 5710 times)

inadiyat

  • Newbie
  • *
  • Posts: 15
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« on: November 24, 2006, 09:30:54 am »

Hi,

I have successfully compiled & installed netxms 0.2.13 on my Linux Box. I would like to upgrade to 0.2.14, but got this error when running ./configure --with-server --with-mysql --with-agent:

configure: error: libmysqlclient is requred for MySQL support

I was facing the same problem when installing 0.2.13, and solved by installing zlib. But now 0.2.14 cannot be compiled with that error, even after I uninstall and re-installing MySQL, MySQL-Dev & zlib.

Please advise...

Below is error a snapshot of config.log:

configure:4438: checking for mysql_init in -lmysqlclient
configure:4468: gcc -o conftest -g -O2 -I/usr/local/include  -D_POSIX_PTHREAD_SEMANTICS -D_XOPEN_SOURCE=500 -D_XOPEN_SOURCE_EXTENDED=1 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/mysql/include -I/usr/include/mysql -I/usr/mysql/include -I/usr/local/include/mysql -I/usr/local/mysql/include/mysql -I/usr/mysql/include/mysql  -L/usr/local/lib -L/usr/local/mysql/lib -L/usr/lib64/mysql -L/usr/lib/mysql -L/usr/mysql/lib -L/usr/local/lib/mysql -L/usr/local/mysql/lib/mysql -L/usr/mysql/lib/mysql conftest.c -lmysqlclient  -lm  >&5
/usr/lib/mysql/libmysqlclient.a(my_compress.o)(.text+0x65): In function `my_compress_alloc':
/home/mysqldev/rpm/BUILD/mysql-5.0.27/libmysql/my_compress.c:58: undefined reference to `compress'
/usr/lib/mysql/libmysqlclient.a(my_compress.o)(.text+0x178): In function `my_uncompress':
/home/mysqldev/rpm/BUILD/mysql-5.0.27/libmysql/my_compress.c:85: undefined reference to `uncompress'
collect2: ld returned 1 exit status
configure:4474: $? = 1
configure: failed program was:
| /* confdefs.h.  */
|
| #define PACKAGE_NAME "NetXMS"
| #define PACKAGE_TARNAME "netxms"
| #define PACKAGE_VERSION "0.2.14"
| #define PACKAGE_STRING "NetXMS 0.2.14"
| #define PACKAGE_BUGREPORT "NetXMS Team <bugs@netxms.org>"
| #define PACKAGE "netxms"
| #define VERSION "0.2.14"
| #ifdef __cplusplus
| extern "C" void std::exit (int) throw (); using std::exit;
| #endif
| #define HAVE_LIBM 1
| #define WITH_MYSQL
| /* end confdefs.h.  */
|
| /* Override any gcc2 internal prototype to avoid an error.  */
| #ifdef __cplusplus
| extern "C"
| #endif
| /* We use char because int might match the return type of a gcc2
|    builtin and then its argument prototype would still apply.  */
| char mysql_init ();
| int
| main ()
| {
| mysql_init ();
|   ;
|   return 0;
| }
configure:4500: result: no
configure:4510: error: libmysqlclient is requred for MySQL support

Best regards,
Adiyat
Logged

Victor Kirhenshtein

  • Lead Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 6509
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« Reply #1 on: November 24, 2006, 11:00:04 am »

Hello!

It's a bug in configure, I'll fix it in next release. For now, try to run configure that way:

LDFLAGS=-lz ./configure --with-server --with-agent --with-mysql

This should help.

Best regards,
Victor
Logged

inadiyat

  • Newbie
  • *
  • Posts: 15
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« Reply #2 on: November 24, 2006, 12:32:54 pm »

Still got the same error...

I am using:

LDFLAGS=-lz ./configure --with-server --with-agent --with-mysql

Regards,
Adiyat
Logged

Alex Kirhenshtein

  • Team Member
  • Administrator
  • Hero Member
  • *****
  • Posts: 912
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« Reply #3 on: November 24, 2006, 02:11:51 pm »

Hello.

Please send me complete config.log to alk at netxms dor org.

wbr, alex.
Logged

inadiyat

  • Newbie
  • *
  • Posts: 15
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« Reply #4 on: November 27, 2006, 10:00:44 am »

Hi, Sorry for late response, I just send you the config.log to [email removed]. Please let me know if you need anything else to troubleshoot this problem.

Thank you for your help.

Bets regards,
Adiyat
« Last Edit: November 14, 2007, 11:44:41 am by Alex Kirhenshtein »
Logged

inadiyat

  • Newbie
  • *
  • Posts: 15
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« Reply #5 on: November 28, 2006, 08:28:15 am »

Hi,

Have you received the log, I sent it a few days ago. Thanks.
Logged

Alex Kirhenshtein

  • Team Member
  • Administrator
  • Hero Member
  • *****
  • Posts: 912
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« Reply #6 on: November 28, 2006, 02:06:04 pm »

Hello.

Yes, i've got the log file yesterday and currently trying to find the problem. Sorry for delay.
Logged

Alex Kirhenshtein

  • Team Member
  • Administrator
  • Hero Member
  • *****
  • Posts: 912
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« Reply #7 on: November 29, 2006, 01:29:16 am »

As workaround, try to apply this patch: http://alk.lv/configure.diff'>http://alk.lv/configure.diff , it should allow you to build server and mysql driver.
Logged

inadiyat

  • Newbie
  • *
  • Posts: 15
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« Reply #8 on: November 29, 2006, 05:23:00 am »

Thanks, I'll give it a try... and will let you know the result.
Logged

inadiyat

  • Newbie
  • *
  • Posts: 15
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« Reply #9 on: November 30, 2006, 08:33:56 am »

Hi,

The problem still there, I just send you 2 files, configure & config.log, hope can help you troubleshoot the problem.

THank you very much to your support.

Best regards,
Adiyat
Logged

Alex Kirhenshtein

  • Team Member
  • Administrator
  • Hero Member
  • *****
  • Posts: 912
    • View Profile
Installing 0.2.14 (upgrading from 0.2.13) on Linux
« Reply #10 on: November 30, 2006, 04:38:12 pm »

I've send you an email with further tests
Logged