NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: Installing console on Mac  (Read 291 times)

edvinl

  • Newbie
  • *
  • Posts: 1
    • View Profile
Installing console on Mac
« on: November 27, 2018, 10:54:05 am »

Hi, I have encountered a problem trying to install the NetXMS console on MacOS Mojave 10.14.1.

Installed NetXMS console 2.2.10
Downloaded Java for OS X 2017-001

Got the following log message when trying to start NetXMS: (had to cut to come under the allowed 20000 characters)

!SESSION 2018-11-27 09:13:05.796 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en
Framework arguments:  -keyring /Users/edvinl/.eclipse_keyring -showlocation /Applications/NetXMS Console.app/Contents/Resources/Java
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -data @user.home/.nxmc/data -keyring /Users/edvinl/.eclipse_keyring -showlocation /Applications/NetXMS Console.app/Contents/Resources/Java

!ENTRY org.eclipse.osgi 2 0 2018-11-27 09:13:07.183
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2018-11-27 09:13:07.184
!MESSAGE Bundle initial@reference:file:plugins/org.netxms.ui.eclipse.filemanager_2.2.10.jar was not resolved.
!SUBENTRY 2 org.netxms.ui.eclipse.filemanager 2 0 2018-11-27 09:13:07.184
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2018-11-27 09:13:07.184
!MESSAGE Bundle initial@reference:file:plugins/org.netxms.ui.eclipse.topology_2.2.10.jar was not resolved.
!SUBENTRY 2 org.netxms.ui.eclipse.topology 2 0 2018-11-27 09:13:07.184
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2018-11-27 09:13:07.184
!MESSAGE Bundle initial@reference:file:plugins/org.netxms.ui.eclipse.policymanager_2.2.10.jar was not resolved.
!SUBENTRY 2 org.netxms.ui.eclipse.policymanager 2 0 2018-11-27 09:13:07.184
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2018-11-27 09:13:07.184
!MESSAGE Bundle initial@reference:file:plugins/org.netxms.ui.base_2.2.10.jar was not resolved.
!SUBENTRY 2 org.netxms.ui.base 2 0 2018-11-27 09:13:07.184
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))".

Break--------------------------------

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-11-27 09:13:07.221
!MESSAGE Bundle org.netxms.ui.eclipse.usermanager_2.2.10 [77] was not resolved.
!SUBENTRY 2 org.netxms.ui.eclipse.usermanager 2 0 2018-11-27 09:13:07.221
!MESSAGE Missing required bundle org.netxms.ui.eclipse.clientlibrary_2.2.10.
!SUBENTRY 2 org.netxms.ui.eclipse.usermanager 2 0 2018-11-27 09:13:07.221
!MESSAGE Missing required bundle org.netxms.ui.eclipse.console_2.2.10.
!SUBENTRY 2 org.netxms.ui.eclipse.usermanager 2 0 2018-11-27 09:13:07.221
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2018-11-27 09:13:07.221
!MESSAGE Bundle org.swtchart_0.7.15 [78] was not resolved.
!SUBENTRY 2 org.swtchart 2 0 2018-11-27 09:13:07.221
!MESSAGE Missing imported package org.netxms.client.datacollection_0.0.0.
!SUBENTRY 2 org.swtchart 2 0 2018-11-27 09:13:07.221
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2018-11-27 09:13:07.221
!MESSAGE Bundle org.netxms.ui.eclipse.objectbrowser.adapterfactory_2.2.10 [243] was not resolved.
!SUBENTRY 2 org.netxms.ui.eclipse.objectbrowser.adapterfactory 2 0 2018-11-27 09:13:07.221
!MESSAGE Missing host org.netxms.ui.eclipse.objectbrowser_2.2.10.

!ENTRY org.eclipse.osgi 4 0 2018-11-27 09:13:07.223
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.netxms.ui.eclipse.console.application" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error.
   at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
   at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
   at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
   at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
Logged

l_rypl

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Installing console on Mac
« Reply #1 on: December 10, 2018, 12:56:00 am »

I had a similar issue, I guess it is caused by using the latest java.
You may want to try installing Java 8 - https://stackoverflow.com/a/28635465/120136.

Regards,
Lukas
Logged