NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: not recognize the option --with-nxhttpd  (Read 3573 times)

Alba

  • Newbie
  • *
  • Posts: 5
    • View Profile
not recognize the option --with-nxhttpd
« on: April 22, 2013, 12:25:56 pm »

I followed the installation of NetXMS-1.2.6 and to all my web server works correctly.
When I get to this point in the manual tells me it does not recognize the - with-nxhttpd.

What do I have to do?
Logged

Alex Kirhenshtein

  • Team Member
  • Administrator
  • Hero Member
  • *****
  • Posts: 912
    • View Profile
Re: not recognize the option --with-nxhttpd
« Reply #1 on: April 23, 2013, 12:57:03 pm »

It's outdated, please use to this guide: http://wiki.netxms.org/wiki/Web_Interface_Installation_Guide
Logged

kwisatz

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: not recognize the option --with-nxhttpd
« Reply #2 on: April 29, 2013, 05:25:52 pm »

I am using netxms 1.2.6 with tomcat but i notice an issue every time i use syslog monitor, i need to restart homepage because netxms web became non responsive...
Logged

Alba

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: not recognize the option --with-nxhttpd
« Reply #3 on: April 30, 2013, 06:07:13 pm »

It's outdated, please use to this guide: http://wiki.netxms.org/wiki/Web_Interface_Installation_Guide


I have followed the steps that you have shown me and I still can not install my web server
Logged

Alex Kirhenshtein

  • Team Member
  • Administrator
  • Hero Member
  • *****
  • Posts: 912
    • View Profile
Re: not recognize the option --with-nxhttpd
« Reply #4 on: May 02, 2013, 03:01:33 am »

Please provide more details about failed step
Logged

Alba

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: not recognize the option --with-nxhttpd
« Reply #5 on: May 02, 2013, 10:31:57 am »

Please provide more details about failed step


I'll explain the steps I followed:

1. I've installed tomcat6.

2. I downloaded the file nxm-1.2.3.war

3. I have copied with the command

                        sudo cp / var/lib/tomcat6/webapps/nxmc-1.2.6.war

4. I changed the permissions with the command

                        sudo chmod 777-1.2.6.war nxmc

5. I get into http://10.0.2.15:8080/nxmc/          (10.0.2.15 is my IP virtual machine)

And I get the following:

           type: Status Report

           Message: / nxmc /

           Description: The requested resource (/ nxmc /) is not available.

What could be my mistake? Thank you.
Logged

Alex Kirhenshtein

  • Team Member
  • Administrator
  • Hero Member
  • *****
  • Posts: 912
    • View Profile
Re: not recognize the option --with-nxhttpd
« Reply #6 on: May 02, 2013, 12:32:31 pm »

Try http://10.0.2.15:8080/nxmc-1.2.6/. By default, Tomcat unpack application into directory matching original war file
Check it:
Code: [Select]
ls -la /var/lib/tomcat6/webapps
If you want to have /nxmc/ URL – rename war file to "nxmc.war"
Logged

Alba

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: not recognize the option --with-nxhttpd
« Reply #7 on: May 02, 2013, 02:14:20 pm »

Try http://10.0.2.15:8080/nxmc-1.2.6/. By default, Tomcat unpack application into directory matching original war file
Check it:
Code: [Select]
ls -la /var/lib/tomcat6/webapps
If you want to have /nxmc/ URL – rename war file to "nxmc.war"


I think my web server works because I get http://10.0.2.15:8080/nxmc-1.2.6/nxmc page to enter my username and password. Does that mean I have already installed?

Sorry if the questions you are very stupid but I am new to all this and I have no experience.

Now I have another problem. I do not know which is my user and my password. Can you tell me how I can look at or know?

Thank you very much.
Logged

Alex Kirhenshtein

  • Team Member
  • Administrator
  • Hero Member
  • *****
  • Posts: 912
    • View Profile
Re: not recognize the option --with-nxhttpd
« Reply #8 on: May 14, 2013, 03:00:13 am »

Yes, if it asked you for login and password – it works.

Default credentials:
Login: "admin"
Password: "netxms"
Logged

Alba

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: not recognize the option --with-nxhttpd
« Reply #9 on: May 19, 2013, 12:11:21 am »

Yes, if it asked you for login and password – it works.

Default credentials:
Login: "admin"
Password: "netxms"

OK. Thanks  :)
Logged