NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: nxdbmgr: symbol lookup error: nxdbmgr: undefined symbol: wgetenv  (Read 1177 times)

adimitrov

  • Jr. Member
  • **
  • Posts: 77
    • View Profile
nxdbmgr: symbol lookup error: nxdbmgr: undefined symbol: wgetenv
« on: September 08, 2016, 11:03:46 am »

Hello team ,

During an upgrade from 2.0.3 to 2.0.6 i got the error in the description ( nxdbmgr: symbol lookup error: nxdbmgr: undefined symbol: wgetenv ). How do i fix this ?

I ran the nxdbmgr check twice before make install (first time fixed some issues, second was all good) and after make install when trying to upgrade the database i got the error. Saw a topic in the forum, but unfortunately in russian and google translate didn't help much.

P.S. last week i upgraded the same machine to latest snapshot without any issues, yesterday i bring the machine back to my latest snapshot so i can test the released version. The machine is debian:

Distributor ID: Debian
Description:    Debian GNU/Linux 7.7 (wheezy)
Release:        7.7
Codename:       wheezy

running on virtual environment.

Best regards,
« Last Edit: September 08, 2016, 11:12:30 am by adimitrov »
Logged

adimitrov

  • Jr. Member
  • **
  • Posts: 77
    • View Profile
Re: nxdbmgr: symbol lookup error: nxdbmgr: undefined symbol: wgetenv
« Reply #1 on: September 08, 2016, 02:35:02 pm »

I was curious if this will happen again and started again from the snapshot, everything went smooth without any issues, exactly the same procedure. I can't get it, what was the issue. However it is fixed now.
« Last Edit: September 08, 2016, 03:03:50 pm by adimitrov »
Logged