NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: Raspberry Pi 3 - Compile Agent  (Read 3767 times)

Tursiops

  • Sr. Member
  • ****
  • Posts: 342
    • View Profile
Raspberry Pi 3 - Compile Agent
« on: May 04, 2016, 03:29:39 am »

Hi,

I'm trying to compile the NetXMS agent from source on a Raspberry Pi 3 (wouldn't mind just using a package instead :) ).
The following command line runs through ok:
Code: [Select]
sudo ./configure --with-agent --with-snmp --with-client --with-client-proxyAfter that I run
Code: [Select]
make
make install
So far so good.

But when I want to actually run the agent (be it via nxagentd or sudo nxagentd, makes no difference), I receive this:
Code: [Select]
nxagentd: error while loading shared libraries: libappagent.so.2: cannot open shared object file: No such file or directory
So I ran
Code: [Select]
ls -l /usr/local/lib/libappagent.* and got this:
Code: [Select]
-rwxr-xr-x 1 root staff  1144 May  3 23:55 libappagent.la
lrwxrwxrwx 1 root staff    20 May  3 23:55 libappagent.so -> libappagent.so.2.0.0
lrwxrwxrwx 1 root staff    20 May  3 23:55 libappagent.so.2 -> libappagent.so.2.0.0
-rwxr-xr-x 1 root staff 45432 May  3 23:55 libappagent.so.2.0.0

To me that looks ok. Not sure why nxagentd has a problem with this?
Any suggestions?
Logged

tomaskir

  • Sr. Member
  • ****
  • Posts: 433
  • https://unimus.net
    • View Profile
Re: Raspberry Pi 3 - Compile Agent
« Reply #1 on: May 04, 2016, 04:21:11 am »

Here are compiled armhf packages.
Logged

Tursiops

  • Sr. Member
  • ****
  • Posts: 342
    • View Profile
Re: Raspberry Pi 3 - Compile Agent
« Reply #2 on: May 04, 2016, 12:00:49 pm »

That worked fine, thanks for the packages.
Now I just don't know what I did wrong with compiling from source? :)
Logged

Tursiops

  • Sr. Member
  • ****
  • Posts: 342
    • View Profile
Re: Raspberry Pi 3 - Compile Agent
« Reply #3 on: May 10, 2016, 03:20:11 am »

Looks like the package didn't come with the SNMP proxy (or I've broken something else), so I guess I'm back to my issue with not being able to get the agent to run after compiling from source.
Logged

tomaskir

  • Sr. Member
  • ****
  • Posts: 433
  • https://unimus.net
    • View Profile
Re: Raspberry Pi 3 - Compile Agent
« Reply #4 on: May 10, 2016, 02:41:18 pm »

It works fine for me from those packages
Code: [Select]
root@raspberrypi:/etc# nxagentd -f -D5
[10-May-2016 13:39:12.363] [INFO ] Additional configs was loaded from /etc/nxagentd.conf.d
[10-May-2016 13:39:12.363] [INFO ] Debug level set to 5
...
[10-May-2016 13:39:12.468] [DEBUG] Thread pool SNMPPROXY initialized (min=2, max=128)
...
[10-May-2016 13:39:14.589] [DEBUG] SNMP Trap sender thread started
[10-May-2016 13:39:14.592] [DEBUG] Data collection scheduler thread started
[10-May-2016 13:39:14.594] [DEBUG] Data sender thread started
[10-May-2016 13:39:14.594] [DEBUG] Database writer thread started
[10-May-2016 13:39:14.594] [DEBUG] Data reconciliation thread started
...
[10-May-2016 13:39:14.598] [DEBUG] SNMPTrapReceiver: listening on 0.0.0.0:162
[10-May-2016 13:39:15.599] [INFO ] NetXMS Agent started
Agent running. Press Ctrl+C to shutdown.
...

What is not working for you?
Logged

nicola

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Raspberry Pi 3 - Compile Agent
« Reply #5 on: June 08, 2016, 11:54:56 am »

Do you by chanche also have the server package?

Thank you for these, in the meanwhile :)

Nicola
Logged

tomaskir

  • Sr. Member
  • ****
  • Posts: 433
  • https://unimus.net
    • View Profile
Re: Raspberry Pi 3 - Compile Agent
« Reply #6 on: June 08, 2016, 12:35:43 pm »

I can give you RPi server packages, but I really do NOT recommend running netxmsd on RPi.

Usually when running the server on RPi, you would use sqlite DB (since you will not have a full featured DB server available).
The NetXMS team has stated multiple times that they want to deprecate sqlite, and sqlite has quite a few known bugs.

Also, unless you have a very good SDHC Card (class 10+ with read/write of 40+ MBps), it will be painfully slow.
Logged

jdowney

  • Newbie
  • *
  • Posts: 44
    • View Profile
Re: Raspberry Pi 3 - Compile Agent
« Reply #7 on: September 14, 2018, 04:25:22 pm »

Thanks for this post I'm running an agent as a proxy in an off-site location running 2.1-M1. Looking to upgrade to 2.2.8 has anyone else already done this and can point me in the right direction.

Thanks

Logged

tomaskir

  • Sr. Member
  • ****
  • Posts: 433
  • https://unimus.net
    • View Profile
Re: Raspberry Pi 3 - Compile Agent
« Reply #8 on: September 15, 2018, 09:24:16 pm »

There is latest up-to-date Raspbian packages in the official NetXMS APT repo.

(This includes 2.2.8 for Raspbian Stretch, and armhf Ubuntu 18 pacakges)
Logged