NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: Reporting Server 2.2.10 (Failed to load reports from the server:...)  (Read 554 times)

91jme

  • Newbie
  • *
  • Posts: 5
    • View Profile

Hi all,

Attempting to get the Reporting Server set up at the minute and can't seem to get past this final hurdle.

Running 2.2.10 on CentOS 7 x64, kernel 3.10.0-862.14.4.el7.x86_64

I've followed instructions here for setup: https://www.netxms.org/documentation/adminguide/reporting.html.

I used the .sql files from https://git.netxms.org/public/reporting-server.git/tree/HEAD:/sql/mysql?js=1 to create the required tables (links in wiki are dead).

Reporting Server seems to start and listen correctly:



Reporting Server is enabled in NetXMS Server however when trying to load the Reports view the following error is received:



I've checked netxmsd.log with debug at 9 and the only reference I can find to Reporting Server is a message that the connector has started:



/usr/local/etc/netxmsd.conf contains the following:



/opt/nxreporting/conf/nxreporting.xml contains:

Code: [Select]
<config>
  <workspace>/opt/nxreporting/workspace</workspace>
    <netxmsdConfig>/usr/local/etc/netxmsd.conf</netxmsdConfig>
    <smtp>
        <server>127.0.0.1</server>
        <from>noreply@netxms.org</from>
    </smtp>
</config>

Any help or tips on troubleshooting this would be greatly appreciated.
« Last Edit: October 29, 2018, 07:02:33 pm by 91jme »
Logged

Tatjana Dubrovica

  • Global Moderator
  • Full Member
  • *****
  • Posts: 225
    • View Profile
Re: Reporting Server 2.2.10 (Failed to load reports from the server:...)
« Reply #1 on: October 30, 2018, 11:59:44 am »

Do you have EnableReportingServer=1 in netxms server configuration(netxmsd.conf)?
This section describes possible additional configuration options: https://www.netxms.org/documentation/adminguide/reporting.html#netxms-server
Logged

91jme

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Reporting Server 2.2.10 (Failed to load reports from the server:...)
« Reply #2 on: October 30, 2018, 04:17:40 pm »

Do you have EnableReportingServer=1 in netxms server configuration(netxmsd.conf)?
This section describes possible additional configuration options: https://www.netxms.org/documentation/adminguide/reporting.html#netxms-server

Hi Tatjana, yes I have the Reporting Server enabled. You can see the configuration option on my third screenshot of the netxmsd.log output:

Quote
name=EnableReportingServer value="1"
Logged

91jme

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Reporting Server 2.2.10 (Failed to load reports from the server:...)
« Reply #3 on: November 01, 2018, 11:08:50 am »

Hi all,

For anybody reading, I think I've fixed the issue. Seems to have been the firewall; I'll list all the troubleshooting steps anyway just in case they help anybody else:

Noticed Java listening on tcp6 (IPv6), switched Java to bind to IPv4 using this command:
export _JAVA_OPTIONS="-Djava.net.preferIPv4Stack=true"
I could't telnet to the server on 4710, which lead me to look at the firewall.
Allowed all traffic on the local interface with the following:
firewall-cmd --permanent --zone=trusted --add-interface=lo
Restarted the reporting engine and netxmsd, waited around 30 seconds and the Report Server perspective loaded correctly:

Logged