NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: Upgrade 2.2.10 -->2.2.12 Segmentation Fault  (Read 202 times)

Meandmybrain

  • Newbie
  • *
  • Posts: 3
    • View Profile
Upgrade 2.2.10 -->2.2.12 Segmentation Fault
« on: February 04, 2019, 05:47:18 pm »

Hi,

I need your help :-\
Today I updated netxms (upgrading netxms-packages) and now netxmsd gets killed straight after starting.
With "netxmsd -D 4" I get following text at the end:

"...
2019.02.04 15:03:42.621 *D* 0 startup scripts processed
2019.02.04 15:03:42.621 *D* Server initialization completed in 2053 milliseconds
2019.02.04 15:03:42.622 *I* NetXMS Server started

NetXMS Server V2.2.12 Build 9516 (UNICODE) Ready
Enter "help" for command list or "down" for server shutdown
System Console

netxmsd: 2019.02.04 15:03:43.620 *D* [action             ] Executing scheduled action [1] for event (null) on node [2453]
2019.02.04 15:03:43.620 *D* [action             ] Executing action 1 (Send E-Mail on node down) of type SEND EMAIL
Segmentation fault"

It seems to me that the server crashes when it is trying to send a Email.(?)
I checked server configs and everything is like before.
I use Ubuntu 18.04 LTS and postgresql on x64.
DB-upgrade was fine and without errors.

Has anybody some helpful suggestions for me?
THX

« Last Edit: February 04, 2019, 06:04:19 pm by Meandmybrain »
Logged

Victor Kirhenshtein

  • Lead Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 6451
    • View Profile
Re: Upgrade 2.2.10 -->2.2.12 Segmentation Fault
« Reply #1 on: February 07, 2019, 11:16:44 am »

Hi!

Do you have a core dump? If not, could you run netxmsd under gdb and when it crashes, issue command bt and provide it's output?

Best regards,
Victor
Logged