NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: Upgrade to 1.2.8 Version  (Read 5744 times)

ademirel

  • Newbie
  • *
  • Posts: 15
    • View Profile
Upgrade to 1.2.8 Version
« on: September 13, 2013, 02:48:35 pm »

Hi,

I try to upgrade from 1.2.7 to 1.2.8 version. It is giving an error when I install the new packages: undefined symbol: wgetenv

What can be the problem? is it a bug?

Regards
Logged

Victor Kirhenshtein

  • Lead Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 6509
    • View Profile
Re: Upgrade to 1.2.8 Version
« Reply #1 on: September 13, 2013, 03:48:37 pm »

Hi!

On what platform you are installing? How do you install server - from sources, from binary package?

Best regards,
Victor
Logged

ademirel

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Upgrade to 1.2.8 Version
« Reply #2 on: September 13, 2013, 03:53:56 pm »

My platform is debian. Firstly, I compiled from source code netxms-1.2.8. And then, I installed debian packages such as agent,base,server.

I did it according to this document.

http://wiki.netxms.org/wiki/Server_Installation_Guide#Upgrading_NetXMS_Server_on_UNIX

Regards
Logged

Victor Kirhenshtein

  • Lead Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 6509
    • View Profile
Re: Upgrade to 1.2.8 Version
« Reply #3 on: September 13, 2013, 04:56:06 pm »

You shouldn't use both methods ion same machine. Most likely you now have two incompatible set of binaries - one under /user and seconds under /usr/local (or other place if you specify --prefix at configure stage). Try to identify wrong binaries and delete them.

Best regards,
Victor
Logged

ademirel

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Upgrade to 1.2.8 Version
« Reply #4 on: September 13, 2013, 05:11:43 pm »

oops, I re-configured it using different prefix and it solved.

Thanks Victor.

Best Regards
Logged