NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: upgrade to 3.0 - from 2.2.10  (Read 123 times)

curruscanis

  • Newbie
  • *
  • Posts: 32
    • View Profile
upgrade to 3.0 - from 2.2.10
« on: September 11, 2019, 09:30:57 pm »

Hello, I am attempting to upgrade my Ubuntu linux ( Ubuntu 16.04.6 LTS ) based NetXMS system from 2.2.10 to 3.0 

I have followed the upgrade instructions on the wiki, although it is out of date.

I have attempted the following...

Downloaded the new release and extracted it:
wget https://netxms.org/download/releases/3.0/netxms-3.0.2258.tar.gz

I then attempted to run the shell program:
sh ./configure --with-server --with-mysql

I get the following error:

....................

checking for sensors/sensors.h... no
checking curl/curl.h usability... no
checking curl/curl.h presence... no
checking for curl/curl.h... no
configure: error: libcurl is required. Check that it is installed or use --without-curl option
 


I do use the --without-curl option I get an error about SSL
.............
checking for sensors/sensors.h... no
checking libssh/libssh.h usability... no
checking libssh/libssh.h presence... no
checking for libssh/libssh.h... no
configure: error: libssh is required for SSH support. Check that it is installed or use --disable-ssh option



I do have Curl installed as well as SSH, I have confirmed this and dont' know why the install script is giving me these errors.

Please let me know if anyone has any advice...



Logged

Victor Kirhenshtein

  • Lead Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 6717
    • View Profile
Re: upgrade to 3.0 - from 2.2.10
« Reply #1 on: September 11, 2019, 10:08:53 pm »

Hi,

first of all I do recommend using precompiled deb packages instead of building form source. Information about repository is here: https://wiki.netxms.org/wiki/Using_APT_Repository

If you want to build server from source, you have to install the following packages:

libssl-dev libcurl4-openssl-dev libexpat1-dev libsqlite3-dev libjansson-dev libssh-dev libmosquitto-dev libpcre3-dev libmysqlclient-dev

Best regards,
Victor
Logged

curruscanis

  • Newbie
  • *
  • Posts: 32
    • View Profile
Re: upgrade to 3.0 - from 2.2.10
« Reply #2 on: September 12, 2019, 04:08:24 pm »

Thank you for that insight Victor, however this is the error that I get when I attempt the following:

apt-get update

..................
Reading package lists... Done
W: The repository 'http://packages.netxms.org/debian xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://packages.netxms.org/debian/dists/xenial/main/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.


.....................


Do you have any further advice?
Logged

curruscanis

  • Newbie
  • *
  • Posts: 32
    • View Profile
Re: upgrade to 3.0 - from 2.2.10
« Reply #3 on: September 12, 2019, 04:38:17 pm »

I think I got it I had a bad entry in my sources list with the NetXMS repository.
Logged