NetXMS Support Forum

Please login or register.

Login with username, password and session length

Author Topic: Исчезновение ILO  (Read 267 times)

eveelu

  • Newbie
  • *
  • Posts: 4
    • View Profile
Исчезновение ILO
« on: April 22, 2019, 04:11:13 pm »

Добрый день. После перехода с версии сервера 2.2.8 на 2.2.13 столкнулся со следующей проблемой: имеется несколько серверов от HP с ILO4. Серверы работают под Windows, на них установлены агенты NetXMS. ILO4 добавлены в NetXMS как отдельные ноды, опрашиваются по SNMP. После обновления объекты с ILO4 стали исчезать из дерева объектов после Configuration pool соответствующего сервера с агентом. Причем это происходит только с теми нодами ILO4, где включен Agentless Management, то есть опрашивается статус сетевых интерфейсов. После рестарта демона netxmsd ноды ILO4 снова отображаются в дереве, до первого Configuration pool. Как временное решение отключил Configuration pool на серверах.

В чем может быть проблема?

Интересный момент, что удалить ноды с ILO через консоль получается, однако, после рестарта демона их снова видно в дереве.

Спасибо
Logged

Victor Kirhenshtein

  • Lead Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 6539
    • View Profile
Re: Исчезновение ILO
« Reply #1 on: April 25, 2019, 10:41:42 am »

В 2.2.13 появилась функция обнаружения нод-дубликатов (с одинаковыми адресами), и в ней уже нашли несколько багов. Попробуйте отключить, выставив параметр сервера NetworkDiscovery.MergeDuplicateNodes в 0.
Logged

eveelu

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Исчезновение ILO
« Reply #2 on: April 29, 2019, 02:10:06 pm »

Большое спасибо, Виктор. Фитчу отключил, больше ноды не пропадают
Logged