Author Topic: Windows 10 nxmc 3.7.144-win32-x64 падает с ошибкой  (Read 225 times)

Akira

  • Full Member
  • ***
  • Posts: 211
    • View Profile
Windows 10 nxmc 3.7.144-win32-x64 падает с ошибкой
« on: February 03, 2021, 08:33:38 am »
причем nxmc-3.7.130-win32-x64.zip работает

Версия явы свежая и 64bit

лог из C:\Users\*\.nxmc\eclipse\

Code: [Select]
!SESSION 2021-02-03 09:28:01.780 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_281
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -data @user.home/.nxmc/data

!ENTRY org.eclipse.debug.core 4 0 2021-02-03 09:28:03.685
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.debug.core [200]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))"

at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1845)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1838)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1779)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1743)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1665)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.e4.ui.bindings 4 0 2021-02-03 09:28:03.716
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.bindings [282]
  Unresolved requirement: Import-Package: org.eclipse.e4.core.commands
    -> Export-Package: org.eclipse.e4.core.commands; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.13.0.v20201119-1132"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,  org.eclipse.e4.ui.workbench,  org.eclipse.e4.ui.workbench.renderers.swt,  org.eclipse.ui.workbench,  org.eclipse.e4.ui.workbench.swt,  org.eclipse.e4.ui.progress,  org.eclipse.e4.core.commands.tests"
       org.eclipse.e4.core.commands [211]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))"
  Unresolved requirement: Import-Package: org.eclipse.e4.core.commands.internal
    -> Export-Package: org.eclipse.e4.core.commands.internal; bundle-symbolic-name="org.eclipse.e4.core.commands"; bundle-version="0.13.0.v20201119-1132"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.bindings,org.eclipse.ui.workbench"
« Last Edit: February 03, 2021, 08:59:04 am by Akira »

Filipp Sudanov

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
    • View Profile
Re: Windows 10 nxmc 3.7.144-win32-x64 падает с ошибкой
« Reply #1 on: February 04, 2021, 12:30:02 pm »
Для последней версии nxmc требуется 11 java (это требование фреймворка, на котором собирается nxmc)

Akira

  • Full Member
  • ***
  • Posts: 211
    • View Profile
Re: Windows 10 nxmc 3.7.144-win32-x64 падает с ошибкой
« Reply #2 on: February 05, 2021, 09:03:17 am »
Для последней версии nxmc требуется 11 java (это требование фреймворка, на котором собирается nxmc)

Мне кажется это хорошо бы указать на странице скачивания в качестве prerequisites

Filipp Sudanov

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
    • View Profile
Re: Windows 10 nxmc 3.7.144-win32-x64 падает с ошибкой
« Reply #3 on: February 22, 2021, 05:45:57 pm »
В следующем релизе планируется паковать нужную версию JRE вместе с nxmc