Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - shroman

Pages: [1]
1
Announcements / Re: NetXMS 2.2.13 released
« on: March 13, 2019, 09:20:56 am »
Is there any documentation to try out TimescaleDB support?

2
Announcements / Re: NetXMS 2.1-M2 released
« on: January 20, 2017, 12:01:56 pm »
Thanks for the quick reply shroman.
That was the solution for that, I didn't needed these 2packages for older versions of NetXMS.

I added the 2lines you suggested to upgrade.cpp after line 886 before I compiled and now it looks like this:
Code: [Select]
         int filteringFlag = 0;
         int objectToolFlag = DBGetFieldLong(hResult, i, 1);

         if (xml == NULL)
             xml = _tcsdup(_T(""));

         // Separate and reorder flags for filter and for object tools

but after compile I get the error "'xml' was not declared in this scope"

Can you help me here again?


Looks liek you have replace line 886, no inserted lines after it:


Code: [Select]


884:         int filteringFlag = 0;
885:         int objectToolFlag = DBGetFieldLong(hResult, i, 1);
886:         TCHAR *xml = DBGetField(hResult, i, 2, NULL, 0);   ->>>>>>
-----------------------
          if (xml == NULL)
            xml = _tcsdup(_T(""));
------------------------
         //Separate and reorder flags for filter and for object tools


3
Announcements / Re: NetXMS 2.1-M2 released
« on: January 20, 2017, 11:14:57 am »
I tried to upgrade our NetXMS V2.1-M1 installation to V2.1-M2 on linux x64. I compile from sources. 'configure' reports error "libssh is required for SSH support". I didn't had this problem compiling V2.1-M1, libssh2 and libssh2-devel ist available on this server. Is there a special version needed?

Thanks for any help.

Dani

You should install libssh package, e.g. in ubuntu:  apt-get install libssh-4 libssh-dev

4
Announcements / Re: NetXMS 2.1-M2 released
« on: January 19, 2017, 04:11:05 pm »
Temporarily fixed the issue by adding the following code to upgrade.cpp after line: 886

----------------------------------
  if (xml == NULL)
            xml = _tcsdup(_T(""));
-----------------------------------



5
Announcements / Re: NetXMS 2.1-M2 released
« on: January 19, 2017, 12:30:51 pm »
Hi,
Having trouble upgrading from M1 -> M2

root@netxms:~/netxms-2.1-M2# /usr/local/netxms/bin/nxdbmgr upgrade
NetXMS Database Manager Version 2.1-M2 Build 9007 (2.1-M2-2-g995c195) (UNICODE)

Upgrading database...
Upgrading from version 417 to 418
Segmentation fault (core dumped)


Additional info runnning gdb: 0x00007ffff6e9022e in wcsrchr () from /lib/x86_64-linux-gnu/libc.so.6

Pages: [1]