NetXMS Support Forum

Please login or register.

Login with username, password and session length

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Spheron

Pages: [1]
1
General Support / Web interface shows Error
« on: February 08, 2019, 01:28:44 pm »
Hello @all,

after Upgrading NetXMS and the NetXMS Webserver from 2.2.11 to 2.2.12 (Windows 7 64bit, MySQL 5.7.24 64bit) i get an error 46 if i call the Website of NetXMS. I'm using Firefox 65.0 (Win64) Version (please see Attachment).

The NetXMS Management Console works without any problems...

Have anyone else this error?

Greets
Marco

2
Installation / Update from 2.2.10 to 2.2.11 - Log Flooding
« on: January 09, 2019, 07:00:00 pm »

Hello @all,

after Upgrade from 2.2.10 to 2.2.11 (Win7 64bit, MySQL 5.7.24) NetXMS Dashboard and Performance Tabs shows randomly "Cannot get Value for DCI XXX (Database Failure)"

If i take a look in de NetXMS Server Log, there are many many lines as the following:


2019.01.09 17:45:35.739 *E* SQL query failed (Query = "SELECT idata_timestamp,idata_value FROM idata_1561 WHERE item_id=? AND idata_timestamp>=? AND idata_timestamp<=? ORDER BY idata_timestamp DESC LIMIT 200000"): Query was empty
2019.01.09 17:45:36.633 *E* SQL query failed (Query = "SELECT idata_timestamp,idata_value FROM idata_1524 WHERE item_id=? AND idata_timestamp>=? AND idata_timestamp<=? ORDER BY idata_timestamp DESC LIMIT 200000"): Query was empty
2019.01.09 17:45:36.645 *E* SQL query failed (Query = "SELECT idata_timestamp,idata_value FROM idata_2405 WHERE item_id=? AND idata_timestamp>=? AND idata_timestamp<=? ORDER BY idata_timestamp DESC LIMIT 200000"): Query was empty
2019.01.09 17:45:37.419 *E* SQL query failed (Query = "SELECT idata_timestamp,idata_value FROM idata_1561 WHERE item_id=? AND idata_timestamp>=? AND idata_timestamp<=? ORDER BY idata_timestamp DESC LIMIT 200000"): Query was empty
2019.01.09 17:45:37.462 *E* SQL query failed (Query = "SELECT idata_timestamp,idata_value FROM idata_2405 WHERE item_id=? AND idata_timestamp>=? AND idata_timestamp<=? ORDER BY idata_timestamp DESC LIMIT 200000"): Query was empty
2019.01.09 17:45:38.134 *E* SQL query failed (Query = "SELECT idata_timestamp,idata_value FROM idata_1561 WHERE item_id=? AND idata_timestamp>=? AND idata_timestamp<=? ORDER BY idata_timestamp DESC LIMIT 200000"): Query was empty


I have run "nxdbmgr check" bevor and after update, but there are no errors...

Should i go back to 2.2.10. ??  Any help is welcome...


Greets
Marco


3
Installation / Install Agent 2.2.1 fails
« on: December 08, 2017, 11:54:30 am »
Hello @all,

if i want to install the Agent 2.2.1 (x64) there are several error messages (please see the attachments). after i quit the installer i take a look at the process explorer (please see attachment).

Here i can see an open handle or file access from the svchost.exe at the nxagent.exe (NetXMS service was quit before).  I can't restart the windows eventlog service in cause of the dependency from scheduler. I could only install the agent after a server reboot.

My first idea: We use NetXMS to trigger an alarm from windows event log with the logwatch subagent. Could there be the problem?

At the moment i tried at 4x Servers (Windows Server 2008 R2 64bit) to install NetXMS Agent. Two via NetXMS Package Manager and two via a manual execution of the agent installer. On all system i have the same behaviour.

Is there anything i can do?


Greets
Marco

4
General Support / Reading List of Windows Performance Counters fails
« on: November 09, 2017, 09:40:15 am »
Hello @all,

if i run a configuratoin poll at a node (Windows Server 2008 R2, 64bit, NetXMS Agent 2.1.2) NetXMS can not read the Windows Performance Counters list. The configuration poll shows the follwing info:

[09.11.2017 08:12:12] **** Poll request sent to server ****
[09.11.2017 08:12:12] Poll request accepted
[09.11.2017 08:12:12] Starting configuration poll for node XXXXXXXXX
[09.11.2017 08:12:12] Checking node's capabilities...
[09.11.2017 08:12:12]    Checking NetXMS agent...
[09.11.2017 08:12:12]    NetXMS native agent is active
[09.11.2017 08:12:12]    Reading list of available Windows Performance Counters...
[09.11.2017 08:12:16]    unable to get Windows Performance Counters list

[09.11.2017 08:12:20] Capability check finished
[09.11.2017 08:12:20] Checking interface configuration...
[09.11.2017 08:12:22] Interface configuration check finished
[09.11.2017 08:12:22] Checking node name
[09.11.2017 08:12:22] Node name is OK
[09.11.2017 08:12:23] Reading list of installed software packages
[09.11.2017 08:12:23] Got information about 38 installed software packages
[09.11.2017 08:12:23] Finished configuration poll for node XXXXXXXXX
[09.11.2017 08:12:23] Node configuration was not changed after poll
[09.11.2017 08:12:23] **** Poll completed successfully ****

The DCI's from this node based on "Windows Performance Counters" are all functional and i can (manually) create new DCIs based on "Windows Performance Counters". But if i want to create a DCI based on "Windows Performance Counters" and use the "Select" button (DCI Properties Windows > General > Data Parameter) the following Windows ("Select Performance Counters") is empty.

We have this behaviour at 3/4 of all our Windows nodes. For the rest of our servers, the Windows Performance Counter query works without problems. All Machines are VMWare VM's, Windows Server 2008 R2 64bit, Updates/Patches are up to date.

We use NetXMS V2.1.2 (Server and Agent). We use NetXMS since V1.0.27. Unfortunately, I can't tell exactly from which version or event (NetXMS Version, Windows Update, etc.) the Windows Performance Counters are not working anymore.

Any help would be appreciated.

Greetings
Marco






5
Configuration / SNMP Walk - Access Denied
« on: October 26, 2017, 06:55:19 pm »

Hello @all,

every time i want to do a snmp walk with the mib-explorer i get the error message " 'Walk MIB tree' has encountered a problem. Cannot do SNMP MIB tree walk: Access Denied". I get this error everytime at every node i want to do a tree walk.

Using NetXMS V2.1.2.

What can i do? Any help would be appreciated.

Greetings
Marco

6
Hello @all,

i use the following script as automatic apply rule in a template (NetXMS V2.1.2):

Code: [Select]
if ( (! $node->isAgent) && (! $node->platformName ~= "windows.*") ) return false;

table = AgentReadTable($node, "System.Services");
if ( table == null ) return false;

colName = table->getColumnIndex("NAME");
for (currentRow = 0; currentRow < table->rowCount; currentRow++)
{
if ( table->get(currentRow, colName) == "DNS" ) return true;
}

return false;


Everytime the script is processed automaticly at a node the following event is thrown:

   Script (Template::Server Service DNS::730) execution error: Error 4 in line 1: Bad arithmetic conversion

but the script is proccessed correctly.


If i create this script in script library and test the script with "Execute Server Script" with a node, there is no error...

Where is my fault?  Thanks for helping me...


Greets
Marco


7
Configuration / 2.1 Sorting Performance Tab
« on: July 13, 2017, 10:48:31 pm »


Hello @all,

since 2.1 the groups feature in performance tab is new designed. Since that change, the order field/function of dci's performance tabs is not working.

It makes a difference in order for the performance tab if a dci is belonging to a group or not. The order no 200 is sorted between dci's with a order no <200. I made the performance tab config in multiple templates.

I fill the order no field in each dci belonging to a group with the same order no. Is this correct?

Have anyone else this problem/behaviour?


Greetings
Marco


8
Hello @all,

wie use policys to deploy the agent configs. One "Master" policy:

<config>
   <agent>
      <MasterServers>XX.XX.XX.XX</MasterServers>
      <ConfigIncludeDir>C:\NetXMS\etc\nxagentd.conf.d</ConfigIncludeDir>
      <LogFile>{syslog}</LogFile>
      <FileStore>C:\NetXMS\var</FileStore>
      <SubAgent>winperf.nsm</SubAgent>
   </agent>
</config>

An one policy to get alarms from windows eventlog:

<config>
   <agent>
      <SubAgent>logwatch.nsm</SubAgent>
   </agent>
   <logwatch>
      <Parser>c:\netxms\var\logwatch_win_eventlog_system_parser.xml</Parser>
      <Parser>c:\netxms\var\logwatch_win_eventlog_application_parser.xml</Parser>
   </logwatch>
</config>


Until Agent 2.0.8 this works without problems. Since i upgraded the agents to 2.1 (64bit), the 2.1 agent is not loading the logwatch subagent.

All 2.0.8 agents have loaded the logwatch subagent and sending windows event is working.

We using NetXMS Server V2.1 64bit on Win7 64bit Host with MySQL 5.6.35 64bit.

Greetings
Marco

 





9
Installation / Upgrade 2.0.8 > 2.1: Perfomance Tab broken
« on: July 12, 2017, 03:18:29 pm »

Hello @all,

since update from 2.0.8 to 2.1 the Grouping from perfomance tab is broken. Group field in performance in settings dialog tab only shows bracket and numbers (ex.: '##1485') and there is no button to select the group dci.

The groups in the perfomance tab are splitt in a graph for each dci.

How can i get this to work as expected? There are no errors at the upgrade from 2.0.8 to 2.1.

Using Windows 7 64-bit (German) as NetXMS Host and MySQL 5.6.35 (64bit) at the same Host as DB.


Greetings
Marco


10
General Support / NetXMS Core Service hangs
« on: March 13, 2017, 10:42:14 am »
Hello @all,

since yesterday i can't login into NetXMS ( V2.0.8 ). I tried to restart the service (Win7, 64bit) but the windows service console always says: starting... netxmsd.exe is always running at 24% cpu. I killed the process and check the db (nxdbmgr check), but there are no error or anything else. All checks are green.

Then i started netxms core with debug log (please see log in attachment) but there are, in my opinion, no errors or so. The last two lines are always:

[13-Mar-2017 09:23:58.177] [DEBUG] AccountStatusUpdater: wakeup
[13-Mar-2017 09:23:58.177] [DEBUG] ConfigReadStr: (cached) name=BlockInactiveUserAccounts value="0"


I don't know what i can further do... I would be grateful for any little help or advice...

Thanx.

Greets
Marco

11
Configuration / Graph from DCI Summary Table
« on: August 16, 2016, 10:55:30 am »

Hello @all,

is there currently a way to create a graph or a line chart from a DCI summary table? I want to visualise the CPU utilization from our servers. I created a summary table but i didn't find a way to create a graph from it...

Thanx for help.

Greets
Marco

12
Configuration / Filtering Script in EventProcessing
« on: June 25, 2015, 01:51:13 pm »

Hello @all,

i'd like to implement a filtering script in event processing:

-----
if ($event->message like “*ERP Basis System*”){
  return false; // Match rule
}
return true;
-----

Event processing should only throw a alarm, if there is NOT the text "ERP Basis System" in the message text of the event. How can/must i use wildcards in filtering scripts?

Thanks for helping me...

Greets
Marco

13
Configuration / Windows Eventlog - No SendTrap() from Agent
« on: April 28, 2015, 07:26:44 pm »
Hello,

i'm using hier NetXMS V1.2.7 in a windows environment (NetXMS server is a Win7 machine, NetXMS Agent runs on a Win2008R2 Server). I'm having here a problem with the monitoring from the Windows server. The NetXMS Agent don't send any events to the NetXMS syslog server (syslog server is up an running...)



My agent config looks like this:
--------------------------------------------
MasterServers = 10.10.9.40
ConfigIncludeDir = C:\NetXMS\etc\nxagentd.conf.d
#LogFile = {syslog}
LogFile = c:\netxms\var\netxms.log
FileStore = C:\NetXMS\var
SubAgent = logwatch.nsm
SubAgent = winperf.nsm
DebugLevel = 9

*LOGWATCH
Parser = c:\netxms\etc\eventlog_system_parser.xml
--------------------------------------------



Logwatch Parser File:
--------------------------------------------
<parser trace="9">
  <file>*System</file>
  <rules>
    <rule>
      <match>(.*)</match>
    </rule>
  </rules>
</parser>
--------------------------------------------



With these configs i can see the following in the NetXMS Agent Log:

--------------------------------------------
[28-Apr-2015 15:45:27.877] [DEBUG] [session:0] Sending message CMD_REQUEST_COMPLETED (size 48)
[28-Apr-2015 15:45:43.492] [DEBUG] LogWatch: publisher name is Service Control Manager
[28-Apr-2015 15:45:43.492] [DEBUG] Match event: source="Service Control Manager" id=7036 level=4 text="Dienst "Software Protection" befindet sich jetzt im Status "Beendet"."
[28-Apr-2015 15:45:43.492] [DEBUG] checking rule 1 ""
[28-Apr-2015 15:45:43.492] [DEBUG]   rule has no context
[28-Apr-2015 15:45:43.492] [DEBUG]   matching against regexp (.*)
[28-Apr-2015 15:45:43.492] [DEBUG]   matched
[28-Apr-2015 15:45:43.492] [DEBUG] rule 1 "" matched
[28-Apr-2015 15:45:43.492] [DEBUG] processing stopped at rule 1 ""; result = true
[28-Apr-2015 15:45:48.250] [DEBUG] [session:0] Message dump:
--------------------------------------------

By searching for infos on Google i can take a look at other NetXMS Agent Dumps with logwatch active. At all other Dumps i can see an

SendTrap(): event ....

after the line "processing stopped at...". Where is my fault? Can anyone help me, please?


Greets
Marco

PS: By the way, thanx for this great piece of software





Pages: [1]