NetXMS Support Forum

Please login or register.

Login with username, password and session length

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - ZacHow

Pages: [1] 2
1
General Support / Re: NetXMS agent takes up 100% CPU
« on: February 22, 2019, 06:03:31 pm »
Hi victor,

Please see link below:
https://1drv.ms/u/s!AmGzVrcqNnJEhn_H0yig5FADmhmg

It's 25mb even when zipped so wouldn't let me upload direct to forum.

Let me know if there's any permissions issues, but it should be a public upload.

Many thanks,

Zac.

2
General Support / Re: NetXMS agent takes up 100% CPU
« on: February 12, 2019, 04:18:05 pm »
Hi Victor, it won't upload due to file size limit. It's 1.24 MB. Seems a little low to me?
Link to download it from One Drive: https://1drv.ms/u/s!AmGzVrcqNnJEhmBaziSAp4xvwbR2
Let me know if there's any issues but the link should be a public download.

3
General Support / Re: NetXMS agent takes up 100% CPU
« on: February 12, 2019, 10:55:33 am »
Hi Victor, Apologies for the delayed response. Had trouble getting these logs, please see attached!

There are an hours worth of logs, but the screenshots within show the exact timestamps for the CPU suddenly rising.
As per the screenshots, its almost as if the agent is freezing for 3 minutes, spiking to 100% CPU and staying there. It's very strange.

Many thanks, Zac.

4
General Support / NetXMS agent takes up 100% CPU
« on: January 29, 2019, 11:11:22 am »
Hi,

We have an issue with one of our servers. As soon as nxagent starts, the CPU jumps to 100%.
We are running the latest version, and we've tried uninstalling / reinstalling. The server is running Windows 2008R2.
We have other 2008R2 servers with the same config on the same network, it's strange that it's only this box which has errors.

Please let me know what logs or information you need to help resolve this issue.

Thanks,

Zac.

5
Configuration / Re: How to monitor non-network services on Centos 7?
« on: January 08, 2019, 11:51:16 am »
I believe you'll have to create an ExternalParameter for that in your Linux agent configuration.
Something like the following should work (not pretty, I'm sure there's better ways):
Code: [Select]
ExternalParameter=System.LinuxService(*):service $1 status|grep Active|sed "s/.*Active: \(.*\) (.*/\1/"
Once you add that to your configuration (manually or via Agent Configuration Policy for any system determined to be running Linux and an Agent), you can reference it in your DCIs as System.LinuxService(<servicename>).

Thank you very much Tursiops! Worked perfectly. It's strange that this isn't in any of the official documentation, it should probably be added if possible.

Another, slightly more complicated question. We have 2 DB servers running Centos7 and MariaDB. Are there any known monitors for DataBase statistics on Centos7 / MariaDB? Is there any way we can achieve this?

Many thanks,

Zac. 

6
Configuration / How to monitor non-network services on Centos 7?
« on: December 27, 2018, 04:31:06 pm »
Hi,

My setup:
Windows server 2012 running NetXMS server (2.2.10)
Centos 7 VM running NetXMS Agent (2.2.10)

On the management console, to monitor a Windows service, we just add "System.servicestate(ServiceName)" and set the expected value. (as shown in attached)

This works fine if the server running the agent is Windows Server 2012/2016/2008R2, but not if the agent is running on a Centos 7 VM.

Any ideas? I've looked all over the forum and the guides but can't seem to find any info!

thanks!

7
Installation / Re: installing on Centos 7
« on: October 30, 2018, 11:39:14 am »
You may find the directory is actually "/usr/local/lib/netxms/".

Thanks for the suggestion. I took a look, and there is a .ddr file, but this doesnt seem to be the DB file. (I have attached screenshot)

I havent changed any settings regarding the DB.

Any other suggestions?

8
Installation / Re: installing on Centos 7
« on: October 26, 2018, 01:37:34 pm »
Hi Victor,

I havent installed SQLite, does it install it as part of the setup process?

There is no file in the location which you pointed me to unfortunately.

Any ideas?

Thanks,

zac.

9
Installation / installing on Centos 7
« on: October 24, 2018, 05:21:58 pm »
Hi,

After installing the agent on Centos 7 and starting the service, I add the server to the management console and I keep getting the attached alarms in alarm browser.

Any ideas? I've specified the log file location in the .config file, the path exists. The install is only the agent, not server, so it shouldnt require a database?

Thanks,

zac.


10
Installation / Re: error installing agent on Centos 7
« on: September 13, 2018, 01:22:26 pm »
you probably want:
yum install libcurl-devel

Thanks, that got me past the 1st error.

now getting this one, what dependency am I missing now?

Is there not a list of them somewhere?

11
Installation / error installing agent on Centos 7
« on: September 11, 2018, 02:49:23 pm »
Hi,

Everything is pretty much summed up in the screenshots. I have libcurl installed and up to date, but NetXMS is saying otherwise!

Please let me know the solution.

Many thanks,

Zac.

12
Installation / Re: Installing NetXMS agent error
« on: April 23, 2018, 10:57:33 am »
Thanks again for the fast reply Victor, much appreciated!

Please see output in screenshot attached.

Many thanks

zac.

13
Installation / Re: Installing NetXMS agent error
« on: April 19, 2018, 11:39:09 am »
Hi Victor,

Thanks for your fast reply!

Unfortunately, same error. I have tried the 32 and 64 bit versions.

Any ideas?

Cheers,

Zac.

14
Installation / Installing NetXMS agent error
« on: April 18, 2018, 03:05:01 pm »
Hello!

I am having trouble installing NetXMS on Centos 7.

I download the file "nxagent-2.2.4-linux-x86_64.tar.gz", extract it, this leaves me with a folder called "opt"

I take the folder called "netxms" FROM the extracted folder, and move to location /opt/

I then run the command shown in screenshot, and get the error "./nxagentd: error while loading shared libraries..." (see screenshot)

I've also tried the 32 bit version to see if that made a dfference, and it didnt.

What am I doing wrong? :(

Any help would be much appreciated

Cheers,

Zac.

15
Installation / SQL Database Error
« on: March 01, 2017, 04:10:32 pm »
Hi all,

I am trying to upgrade NetXMS. Here is what is happening:

I disable the NetXMS Service.
I run the following command in CMD: "C:\NetXMS\bin nxdbmgr check". This command gives me no error codes / all the output is green and has no faults.
I run the installer from CMD with /SILENT at the end.
Half way through the install, it stops in install SQL, which gives me the error shown in the screenshot.

I cannot uninstall SQL as we use it for other applications on this server. The server is running windows 2012. The version of NetXMS I am trying to install is 2.0.8 (x64).

Any help or advice would be much appreciated.

Thanks,

Zac  :)

Pages: [1] 2