Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - gokiwi

Pages: [1]
1
General Support / Re: TP-Link Help
« on: August 15, 2020, 01:05:40 pm »
snmpwalk returns data  - what I did was delete the original and add manually this then worked. Unfortunately TP-Link obviously do not implement snmp properly or fully (for example you cannot see the 4 gigabit interfaces).

(this is just an extract)

C:\NetXMS\bin>nxsnmpwalk -v 2c -c Monday1964! 192.168.1.1 .1
.1.3.6.1.2.1.1.1.0 [STRING]: 0.5.0 0.9.1 v0069.0 Build 200624 Beta.68497n
.1.3.6.1.2.1.1.2.0 [OBJECT IDENTIFIER]: .1.3.6.1.4.1.16972
.1.3.6.1.2.1.1.3.0 [TIMETICKS]: 60955700
.1.3.6.1.2.1.1.4.0 [STRING]: Scott Dawson
.1.3.6.1.2.1.1.5.0 [STRING]: Folly-VR900-Router
.1.3.6.1.2.1.1.6.0 [STRING]: Downstairs Office
.1.3.6.1.2.1.1.7.0 [INTEGER]: 72
.1.3.6.1.2.1.1.8.0 [TIMETICKS]: 0
.1.3.6.1.2.1.1.9.1.2.1 [OBJECT IDENTIFIER]: .1.3.6.1.6.3.1
.1.3.6.1.2.1.1.9.1.3.1 [STRING]: The MIB module for SNMPv2 entities
.1.3.6.1.2.1.1.9.1.4.1 [TIMETICKS]: 0
.1.3.6.1.2.1.2.1.0 [INTEGER]: 20
.1.3.6.1.2.1.2.2.1.1.2 [INTEGER]: 2
.1.3.6.1.2.1.2.2.1.1.4 [INTEGER]: 4
.1.3.6.1.2.1.2.2.1.1.8 [INTEGER]: 8
.1.3.6.1.2.1.2.2.1.1.16 [INTEGER]: 16
.1.3.6.1.2.1.2.2.1.1.17 [INTEGER]: 17
.1.3.6.1.2.1.2.2.1.1.19 [INTEGER]: 19
.1.3.6.1.2.1.2.2.1.1.20 [INTEGER]: 20
.1.3.6.1.2.1.2.2.1.2.2 [STRING]: ifb0
.1.3.6.1.2.1.2.2.1.2.4 [STRING]: gre0
.1.3.6.1.2.1.2.2.1.2.8 [STRING]: bcmsw
.1.3.6.1.2.1.2.2.1.2.16 [STRING]: br0
.1.3.6.1.2.1.2.2.1.2.17 [STRING]: tun0
.1.3.6.1.2.1.2.2.1.2.19 [STRING]: ptm0.101
.1.3.6.1.2.1.2.2.1.2.20 [STRING]: ppp1
.1.3.6.1.2.1.2.2.1.3.2 [INTEGER]: 6
.1.3.6.1.2.1.2.2.1.3.4 [INTEGER]: 6
.1.3.6.1.2.1.2.2.1.3.8 [INTEGER]: 6
.1.3.6.1.2.1.2.2.1.3.16 [INTEGER]: 6
.1.3.6.1.2.1.2.2.1.3.17 [INTEGER]: 6
.1.3.6.1.2.1.2.2.1.3.19 [INTEGER]: 6
.1.3.6.1.2.1.2.2.1.3.20 [INTEGER]: 23
.1.3.6.1.2.1.2.2.1.4.2 [INTEGER]: 1500
.1.3.6.1.2.1.2.2.1.4.4 [INTEGER]: 1476
.1.3.6.1.2.1.2.2.1.4.8 [INTEGER]: 1500
.1.3.6.1.2.1.2.2.1.4.16 [INTEGER]: 1500
.1.3.6.1.2.1.2.2.1.4.17 [INTEGER]: 1500
.1.3.6.1.2.1.2.2.1.4.19 [INTEGER]: 1500
.1.3.6.1.2.1.2.2.1.4.20 [INTEGER]: 1480
.1.3.6.1.2.1.2.2.1.5.2 [GAUGE32]: 100000000
.1.3.6.1.2.1.2.2.1.5.4 [GAUGE32]: 100000000
.1.3.6.1.2.1.2.2.1.5.8 [GAUGE32]: 100000000
.1.3.6.1.2.1.2.2.1.5.16 [GAUGE32]: 100000000
.1.3.6.1.2.1.2.2.1.5.17 [GAUGE32]: 100000000
.1.3.6.1.2.1.2.2.1.5.19 [GAUGE32]: 100000000

2
General Support / TP-Link Help
« on: August 13, 2020, 09:58:49 pm »
Hi All,

I have several TP-Link devices (Archer VR900 ADSL Router, WA901 Wireless Access Point) , the all support snmp v2 (but use a "public" mib).
I am testing NETXMS alongside Zabbix - Unfortunately Zabbix picks up the interfaces on these where as NetXMS does not  - What am I doing wrong ?

This is the response

[13.08.2020 19:50:28] **** Poll request sent to server ****
[13.08.2020 19:50:28] Poll request accepted
[13.08.2020 19:50:28] Starting configuration poll for node Folly-VR900-Router
[13.08.2020 19:50:28] Checking node's capabilities...
[13.08.2020 19:50:28]    Checking NetXMS agent...
[13.08.2020 19:50:30]    Cannot connect to NetXMS agent (Connect failed)
[13.08.2020 19:50:30]    Checking SNMP...
[13.08.2020 19:51:29]    Checking EtherNet/IP...
[13.08.2020 19:51:31]    Cannot get device identity via EtherNet/IP (CONNECT FAILED)
[13.08.2020 19:51:31] Capability check finished
[13.08.2020 19:51:31] Checking interface configuration...
[13.08.2020 19:51:31] Unable to get interface list from node
[13.08.2020 19:51:31] Interface configuration check finished
[13.08.2020 19:51:31] Checking node name
[13.08.2020 19:51:31] Node name is OK
[13.08.2020 19:51:31] Updating general system hardware information
[13.08.2020 19:51:31] Finished configuration poll for node Folly-VR900-Router
[13.08.2020 19:51:31] Node configuration was not changed after poll
[13.08.2020 19:51:31] **** Poll completed successfully ****

3
General Support / Re: LinuxMint 20.04 Installation issues
« on: July 31, 2020, 04:13:27 pm »
We have lift off - Everyday that you learn something is a good day !!! - Thank you for your help & assistance  - much appreciated

4
General Support / Re: LinuxMint 20.04 Installation issues
« on: July 30, 2020, 07:16:55 pm »
Hi, Again thanks for the reply.

I did somehow get it working briefly last night , but then today LM 20.04 had some updates that required a reboot and now it doesn't work again.

The daemon I think is running.

sudo systemctl status netxmsd
● netxmsd.service - NetXMS Server
     Loaded: loaded (/lib/systemd/system/netxmsd.service; disabled; vendor pres>
     Active: active (running) since Thu 2020-07-30 15:44:22 BST; 1h 29min ago
    Process: 5220 ExecStart=/usr/bin/netxmsd -d (code=exited, status=0/SUCCESS)
   Main PID: 5233 (netxmsd)
      Tasks: 94 (limit: 9304)
     Memory: 32.2M
     CGroup: /system.slice/netxmsd.service
             └─5233 /usr/bin/netxmsd -d

Jul 30 15:44:22 Hampton-Downs systemd[1]: Starting NetXMS Server...
Jul 30 15:44:22 Hampton-Downs systemd[1]: Started NetXMS Server.

But when I try to login via ncmc I get

Connection Error - Access denied.

I have followed the instructions to reset the password (which seemed to be successful)
 

5
General Support / Re: LinuxMint 20.04 Installation issues
« on: July 30, 2020, 12:27:30 am »
Hi , Thanks for the quick response - unfortunately it still doesn't work - Ive done a fresh install of 20.04  and a fresh install of Netxms. The provided instructions are both wrong and confusing .

I now get the following errors

sudo /usr/bin/nxdbmgr init
NetXMS Database Manager Version 3.4.232 Build 3.4-232-g55c414782e (UNICODE)

Unable to load and initialize database driver ""

and

sudo systemctl start netxms-server
Failed to start netxms-server.service: Unit netxms-server.service not found.

Postgresql is running and listening on port 5432




6
General Support / LinuxMint 20.04 Installation issues
« on: July 29, 2020, 09:56:05 pm »
Hi, Trying to install on LM20.04 but am hitting issues.

I have both PostgreSQL and MySQL installed - have installed the driver for PostgreSQL as when I try and install the driver for MySQL it says

sudo apt-get install netxms-dbdrv-mysql
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package netxms-dbdrv-mysql

I then try "/usr/local/bin/nxdbmgr init" but get
/user/local/bin/nxdbmgr init
bash: /user/local/bin/nxdbmgr: No such file or directory


Also I dont see anywhere where it says how to launch the webgui ?








7
Cancel that ! - Just found it  :o

8
General Support / Dashboard View for interface on Win 10 agent only
« on: June 15, 2020, 10:19:44 pm »
So I have 3 machines all running Windows 10 and the netxms agent, when I try to create a Dashboard view all I see is the agent provided information but this does not include any network adaptors.

Must be missing something but cannot see what

9
General Support / Re: Linux Agent
« on: June 15, 2020, 06:34:07 pm »
Hi,

Was Firewall on Linux machine  - for some reason although the rule was set for both directions it wasnt working inbound - created two seperate rules inbound and outbound and it started working !!.

10
General Support / Re: Linux Agent
« on: June 12, 2020, 07:35:19 pm »
Was too hasty - still not working.

Error message when trying to poll

[12.06.2020 17:33:08] **** Poll request sent to server ****
[12.06.2020 17:33:08] Poll request accepted
[12.06.2020 17:33:09] Starting configuration poll for node Hampton-Downs
[12.06.2020 17:33:09] Checking node's capabilities...
[12.06.2020 17:33:09]    Checking NetXMS agent...
[12.06.2020 17:33:14]    Cannot connect to NetXMS agent (Connect failed)
[12.06.2020 17:33:14]    Checking EtherNet/IP...
[12.06.2020 17:33:19]    Cannot get device identity via EtherNet/IP (CONNECT FAILED)
[12.06.2020 17:33:19] Capability check finished
[12.06.2020 17:33:19] Checking interface configuration...
[12.06.2020 17:33:28] Unable to get interface list from node
[12.06.2020 17:33:28] Interface configuration check finished
[12.06.2020 17:33:28] Checking node name
[12.06.2020 17:33:28] Node name is OK
[12.06.2020 17:33:28] Updating general system hardware information
[12.06.2020 17:33:42] Finished configuration poll for node Hampton-Downs
[12.06.2020 17:33:42] Node configuration was not changed after poll
[12.06.2020 17:33:42] **** Poll completed successfully ****

Error message from service status

xagentd.service - NetXMS Agent
   Loaded: loaded (/lib/systemd/system/nxagentd.service; enabled; vendor preset:
   Active: active (running) since Fri 2020-06-12 13:53:37 BST; 3h 39min ago
  Process: 12387 ExecStart=/usr/bin/nxagentd -d (code=exited, status=0/SUCCESS)
 Main PID: 12388 (nxagentd)
    Tasks: 18 (limit: 4915)
   CGroup: /system.slice/nxagentd.service
           └─12388 /usr/bin/nxagentd -d

Jun 12 13:53:34 Hampton-Downs systemd[1]: Starting NetXMS Agent...
Jun 12 13:53:34 Hampton-Downs systemd[1]: nxagentd.service: Can't open PID file
Jun 12 13:53:37 Hampton-Downs systemd[1]: Started NetXMS Agent.

11
General Support / Re: Linux Agent
« on: June 12, 2020, 03:50:46 pm »
You are a genius  - that did it ! - Very many thanks for your help , most appreciated.

12
General Support / Re: Linux Agent
« on: June 12, 2020, 01:21:41 pm »
Hi,

Unfortunately my newness to Linux has seen me fail at the first hurdle !!,

when running sudo apt-get update it fails with
W: GPG error: http://packages.netxms.org/debian stretch InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 179C0A80CDFADDB1
E: The repository 'http://packages.netxms.org/debian stretch InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I tried reading the manpage as recommended but failed badly..

Not sure what to do next, beginning to think this learning curve is too steep for someone in their late 50's

Resolved the above but now get

The following information may help to resolve the situation:

The following packages have unmet dependencies.
 netxms-agent : Depends: netxms-base (= 3.3.350-1) but it is not going to be installed
                Depends: netxms-dbdrv-sqlite3 (= 3.3.350-1) but it is not going to be installed
                Depends: libssl1.0.2 (>= 1.0.2d) but it is not installable
E: Unable to correct problems, you have held broken packages.

13
General Support / Linux Agent
« on: June 10, 2020, 04:48:47 pm »
Hi,

Is there a detailed set of instructions to install the agent on Linux, specifically Linux Mint 19 (I'm a complete Linux newbie) ?

I downloaded a Linux agent from the website and unarchieved it but all it has is /opt/netxms/bin and /opt/netxms/lib  - there are files in both directories but no sort of installer or instructions on what to do next.

I should add that I have installed net-snmp on the same box and set the rocommunity string but this does not seem to work (probably because I havnt a clue what I'm doing) (Learning when youre old can be a bit painful)

regards

14
General Support / More newbie issues
« on: June 05, 2020, 01:59:38 pm »
So after a successful install on my laptop I want to move to my desktop however I cannot install as hit a database issue.
I am trying to install over RDP on a Windows 10 Build 1909 machine Core i5 and 8Gb Ram.

I have installed Postgresql 12 and set the password .
Installed NetXMMS and run the configuration wizard , put the Postgresql details in

Database Engine : Postgresql
Driver : pgsql ddr
Database server : localhost
DBA Login : postgres
DBA password : password123
Database name : netxms_db
DB Login : netxms
DB Password : apassword

Service dependancies : postgresql-x64-12

"Error loading database driver"

Am completely lost at this point




15
General Support / New User and already in trouble
« on: June 04, 2020, 12:57:49 pm »
Hello,

New user to NetXMS and got myself in a bit of a confused state !, I have several Windows 10 machines (Linux and Windows Servers as well)I wish to monitor and these have been discovered in my initial scan but are state "unknown".

Do I have to install an agent on each machine or can I use WMI (and if so how ? - as I cannot see where you add WMI credentials)

Regards

Pages: [1]